Ubuntu 9.10 : Adding and automounting a second hard drive

I really should document things like this while I’m doing it and not after the fact. This is how I think it went. I was given and old hard drive. I figured I’d add it to the Ubuntu 9.10 install that I’m using as kind of a media server. It would be nice to have a second hard drive that just contains media. In the end, the hard drive was trashed, but I will repeat this process with a new hard drive soon. I think I need a terabyte drive anyway.

The PC involved/Hardware:
MB: Epox: EP 8RDA3+ Pro
CPU: AMD Athlon XP 2400+ (2Ghz)
Ram: 1.5 Gig
Video Card: Nvidia GeForce 4 Ti 4200
HD1: Western Digital 120 GB drive (IDE)
Adding HD2: 300 GB Western Digital (IDE)

First thing I did was shut down the computer. I made sure HD1 and HD2 were both jumped CS (Cable Select). I connected HD2 to the secondary position(middle) of the IDE cable. Connected the power plug and turned the computer back on. I’m not sure why but I was expecting it not to boot… but it did.

HD2 showed up in nautilus, but it was not mounted. If I click on it, I need to enter my password to mount it. I’ll deal with this later. I need to format the drive first. I went to System > Administration > Disk Utility. Selected HD2, deleted the current partition, formated it ext4 and I believe I was asked if I wanted to take ownership of the drive… I think. Well I did. Oh yea, It asked for a new volume name and I called it bucket. I’m gonna be tossing a lot of stuff in.. the… bucket…. …. nevermind.

At that point I could open nautilus, click on bucket, enter my password to mount the drive to read and write to HD2(bucket). I tried to navigate to this drive with mediatomb and was informed that mediatomb does not have permission to access this drive. Ok. Anyway, nautilus looks like this right now.That’s after I manually mount HD2(bucket).

I have to edit the /etc/fstab file to automount HD2. So I opened a terminal and typed:
$ sudo gedit /etc/fstab

It looked like this:

After a lot of research on the net, I narrowed my entry down to this:
/dev/sdb1 /media/bucket ext4 rw,user,auto,exec 0 0
I got the /dev/sdb1 /media/bucket information from the disk utility at System > Administration > Disk Utility. I also had to create the mount point. I opened nautilus with root privileges:
$ gksudo nautilus
I then made my way to /media and made a folder named bucket.
My fstab file now looks like this:

I commented above my entry there at the end. It works. It is mounted when the machine boots and read write access for myself and other programs(mediatomb) is not a problem. I’m going to be doing this again real soon because this disk is trashed.

About these ads

1 comment so far

  1. Theron on

    Thanks, Terry – this is just what I was looking for, you’ve saved me a lot of time and confusion!


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: